import re
regex = re.compile(r"#([^\s\p{P}]*)\S+", flags=re.MULTILINE)
test_str = "Android Wear testen doen we met de Sony #Smartwatch3. Binnenkort volgt een uitgebreide review op de website ;-)"
subst = "<a href=\"https://www.facebook.com/hashtag/$1\" title=\"$1\">$1</a>"
result = regex.sub(subst, test_str)
if result:
print(result)