re = /#([^\s\p{P}]*)\S+/m
str = 'Android Wear testen doen we met de Sony #Smartwatch3. Binnenkort volgt een uitgebreide review op de website ;-)'
subst = '<a href="https://www.facebook.com/hashtag/$1" title="$1">$1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result