package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)#([^\s\p{P}]*)\S+`)
var str = `Android Wear testen doen we met de Sony #Smartwatch3. Binnenkort volgt een uitgebreide review op de website ;-)`
var substitution = "<a href="https://www.facebook.com/hashtag/$1" title="$1">$1</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}