#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<div\s+username="pepper">(?:(?!<\/div>)[\s\S])*?location.*?\s+<td>([^<]*)"
Local $sString = "<div username="bob">" & @CRLF & _
" <table>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>name</td>" & @CRLF & _
" <td>alex</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>location</td>" & @CRLF & _
" <td>London</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>id</td>" & @CRLF & _
" <td>123</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </table>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div username="apple">" & @CRLF & _
" <table>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>name</td>" & @CRLF & _
" <td>david</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>id</td>" & @CRLF & _
" <td>321</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </table>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div username="pepper">" & @CRLF & _
" <table>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>location</td>" & @CRLF & _
" <td>Bradford</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </table>" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")