using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div\s+username=""pepper"">(?:(?!<\/div>)[\s\S])*?location.*?\s+<td>([^<]*)";
string input = @"<div username=""bob"">
<table>
<tr>
<td>name</td>
<td>alex</td>
</tr>
<tr>
<td>location</td>
<td>London</td>
</tr>
<tr>
<td>id</td>
<td>123</td>
</tr>
</table>
</div>
<div username=""apple"">
<table>
<tr>
<td>name</td>
<td>david</td>
</tr>
<tr>
<td>id</td>
<td>321</td>
</tr>
</table>
</div>
<div username=""pepper"">
<table>
<tr>
<td>location</td>
<td>Bradford</td>
</tr>
</table>
</div>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}