$re = '/<div\s+username="pepper">(?:(?!<\/div>)[\s\S])*?location.*?\s+<td>([^<]*)/i';
$str = '<div username="bob">
<table>
<tr>
<td>name</td>
<td>alex</td>
</tr>
<tr>
<td>location</td>
<td>London</td>
</tr>
<tr>
<td>id</td>
<td>123</td>
</tr>
</table>
</div>
<div username="apple">
<table>
<tr>
<td>name</td>
<td>david</td>
</tr>
<tr>
<td>id</td>
<td>321</td>
</tr>
</table>
</div>
<div username="pepper">
<table>
<tr>
<td>location</td>
<td>Bradford</td>
</tr>
</table>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);