import re
regex = re.compile(r"<div\s+username=\"pepper\">(?:(?!<\/div>)[\s\S])*?location.*?\s+<td>([^<]*)", flags=re.IGNORECASE)
test_str = ("<div username=\"bob\">\n"
" <table>\n"
" <tr>\n"
" <td>name</td>\n"
" <td>alex</td>\n"
" </tr>\n"
" <tr>\n"
" <td>location</td>\n"
" <td>London</td>\n"
" </tr>\n"
" <tr>\n"
" <td>id</td>\n"
" <td>123</td>\n"
" </tr>\n"
" </table>\n"
" </div>\n\n"
" <div username=\"apple\">\n"
" <table>\n"
" <tr>\n"
" <td>name</td>\n"
" <td>david</td>\n"
" </tr>\n"
" <tr>\n"
" <td>id</td>\n"
" <td>321</td>\n"
" </tr>\n"
" </table>\n"
" </div>\n\n"
" <div username=\"pepper\">\n"
" <table>\n"
" <tr>\n"
" <td>location</td>\n"
" <td>Bradford</td>\n"
" </tr>\n"
" </table>\n"
" </div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")