import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div\\s+username=\"pepper\">(?:(?!<\\/div>)[\\s\\S])*?location.*?\\s+<td>([^<]*)";
final String string = "<div username=\"bob\">\n"
+ " <table>\n"
+ " <tr>\n"
+ " <td>name</td>\n"
+ " <td>alex</td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td>location</td>\n"
+ " <td>London</td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td>id</td>\n"
+ " <td>123</td>\n"
+ " </tr>\n"
+ " </table>\n"
+ " </div>\n\n"
+ " <div username=\"apple\">\n"
+ " <table>\n"
+ " <tr>\n"
+ " <td>name</td>\n"
+ " <td>david</td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td>id</td>\n"
+ " <td>321</td>\n"
+ " </tr>\n"
+ " </table>\n"
+ " </div>\n\n"
+ " <div username=\"pepper\">\n"
+ " <table>\n"
+ " <tr>\n"
+ " <td>location</td>\n"
+ " <td>Bradford</td>\n"
+ " </tr>\n"
+ " </table>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}