use strict;
my $str = '<div username="bob">
<table>
<tr>
<td>name</td>
<td>alex</td>
</tr>
<tr>
<td>location</td>
<td>London</td>
</tr>
<tr>
<td>id</td>
<td>123</td>
</tr>
</table>
</div>
<div username="apple">
<table>
<tr>
<td>name</td>
<td>david</td>
</tr>
<tr>
<td>id</td>
<td>321</td>
</tr>
</table>
</div>
<div username="pepper">
<table>
<tr>
<td>location</td>
<td>Bradford</td>
</tr>
</table>
</div>';
my $regex = qr/<div\s+username="pepper">(?:(?!<\/div>)[\s\S])*?location.*?\s+<td>([^<]*)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}