const regex = /<div\s+username="pepper">(?:(?!<\/div>)[\s\S])*?location.*?\s+<td>([^<]*)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div\\s+username="pepper">(?:(?!<\\\/div>)[\\s\\S])*?location.*?\\s+<td>([^<]*)', 'gi')
const str = `<div username="bob">
<table>
<tr>
<td>name</td>
<td>alex</td>
</tr>
<tr>
<td>location</td>
<td>London</td>
</tr>
<tr>
<td>id</td>
<td>123</td>
</tr>
</table>
</div>
<div username="apple">
<table>
<tr>
<td>name</td>
<td>david</td>
</tr>
<tr>
<td>id</td>
<td>321</td>
</tr>
</table>
</div>
<div username="pepper">
<table>
<tr>
<td>location</td>
<td>Bradford</td>
</tr>
</table>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}