import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<!(--(?:[^-]|-(?!->))*?--)>)(?!((?!<%--)[\\s\\S])*?--%>)";
final String string = "Condition: 1 : <!-- normal HTML comment -->\n\n"
+ "Codition: 2 <%-- normal JSP comment \n"
+ " <!-- inside html comment here -->\n"
+ " other comment stuff\n"
+ " <!-- another inside html comment here -->\n"
+ "--%>\n"
+ "Condition: 1 : <!-- normal HTML comment -->\n\n\n\n";
final String subst = "<%$2%>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}