re = /(<!(--(?:[^-]|-(?!->))*?--)>)(?!((?!<%--)[\s\S])*?--%>)/
str = 'Condition: 1 : <!-- normal HTML comment -->
Codition: 2 <%-- normal JSP comment
<!-- inside html comment here -->
other comment stuff
<!-- another inside html comment here -->
--%>
Condition: 1 : <!-- normal HTML comment -->
'
subst = '<%$2%>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result