const regex = /(<!(--(?:[^-]|-(?!->))*?--)>)(?!((?!<%--)[\s\S])*?--%>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<!(--(?:[^-]|-(?!->))*?--)>)(?!((?!<%--)[\\s\\S])*?--%>)', 'g')
const str = `Condition: 1 : <!-- normal HTML comment -->
Codition: 2 <%-- normal JSP comment
<!-- inside html comment here -->
other comment stuff
<!-- another inside html comment here -->
--%>
Condition: 1 : <!-- normal HTML comment -->
`;
const subst = `<%$2%>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);