import re
regex = re.compile(r"(<!(--(?:[^-]|-(?!->))*?--)>)(?!((?!<%--)[\s\S])*?--%>)")
test_str = ("Condition: 1 : <!-- normal HTML comment -->\n\n"
"Codition: 2 <%-- normal JSP comment \n"
" <!-- inside html comment here -->\n"
" other comment stuff\n"
" <!-- another inside html comment here -->\n"
"--%>\n"
"Condition: 1 : <!-- normal HTML comment -->\n\n\n\n")
subst = "<%$2%>"
result = regex.sub(subst, test_str)
if result:
print(result)