# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([ ]*)(class)[ ]+([a-zA-Z]\S*).*/protected void new()\n{\n}\n\npublic static \3 construct()\n{\n\treturn new \3();\n}\n/g;t' <<< "class GTECostSheetFactorParameters"