import re
regex = re.compile(r"([ ]*)(class)[ ]+([a-zA-Z]\S*).*")
test_str = "class GTECostSheetFactorParameters"
subst = "protected void new()\\n{\\n}\\n\\npublic static \\3 construct()\\n{\\n\\treturn new \\3();\\n}\\n"
result = regex.sub(subst, test_str)
if result:
print(result)