import Foundation
let pattern = #"([ ]*)(class)[ ]+([a-zA-Z]\S*).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"class GTECostSheetFactorParameters"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"protected void new()\n{\n}\n\npublic static \3 construct()\n{\n\treturn new \3();\n}\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)