import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([ ]*)(class)[ ]+([a-zA-Z]\\S*).*";
final String string = "class GTECostSheetFactorParameters";
final String subst = "protected void new()\\n{\\n}\\n\\npublic static \\3 construct()\\n{\\n\\treturn new \\3();\\n}\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}