// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([ ]*)(class)[ ]+([a-zA-Z]\S*).*").unwrap();
let string = "class GTECostSheetFactorParameters";
let substitution = "protected void new()\\n{\\n}\\n\\npublic static \\3 construct()\\n{\\n\\treturn new \\3();\\n}\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}