package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([ ]*)(class)[ ]+([a-zA-Z]\S*).*`)
var str = `class GTECostSheetFactorParameters`
var substitution = "protected void new()\n{\n}\n\npublic static \3 construct()\n{\n\treturn new \3();\n}\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}