$re = '/([ ]*)(class)[ ]+([a-zA-Z]\S*).*/';
$str = 'class GTECostSheetFactorParameters';
$subst = "protected void new()\n{\n}\n\npublic static \3 construct()\n{\n\treturn new \3();\n}\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;