#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s*$\n|\r"
Local $sString = " <Formula>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" double dn=a+b;" & @CRLF & _
" if (dn==0) then" & @CRLF & _
" return 0;" & @CRLF & _
" " & @CRLF & _
" return (c+d)/dn;; " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" </Formula>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)