import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*$\\n|\\r";
final String string = " <Formula>\n\n\n"
+ " \n"
+ " \n"
+ " double dn=a+b;\n"
+ " if (dn==0) then\n"
+ " return 0;\n"
+ " \n"
+ " return (c+d)/dn;; \n"
+ " \n"
+ " \n\n"
+ " </Formula>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}