// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*$\n|\r").unwrap();
let string = " <Formula>
double dn=a+b;
if (dn==0) then
return 0;
return (c+d)/dn;;
</Formula>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}