re = /^\s*$\n|\r/m
str = ' <Formula>
double dn=a+b;
if (dn==0) then
return 0;
return (c+d)/dn;;
</Formula>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result