# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*$\n|\r"
test_str = (" <Formula>\n\n\n"
" \n"
" \n"
" double dn=a+b;\n"
" if (dn==0) then\n"
" return 0;\n"
" \n"
" return (c+d)/dn;; \n"
" \n"
" \n\n"
" </Formula>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.