import Foundation
let pattern = #"^\s*$\n|\r"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<Formula>
double dn=a+b;
if (dn==0) then
return 0;
return (c+d)/dn;;
</Formula>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)