# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(http[s]?):(\\/+)/$1:\/\//gm;t' <<< "/@https:/www.shouldmatch.com
/@http:/www.shouldmatch.com
/@https://www.shouldnotmatch.com
/@https:/www.shouldmatchtwice.com?url=https:/cp.com
/@https:/www.shouldmatchtwice.com?url=http:/cp.com
/@https:/www.shouldmatchonce.com?url=https://cp.com
/@keyword
/directory
/
"