package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(http[s]?):(\/+)`)
var str = `/@https:/www.shouldmatch.com
/@http:/www.shouldmatch.com
/@https://www.shouldnotmatch.com
/@https:/www.shouldmatchtwice.com?url=https:/cp.com
/@https:/www.shouldmatchtwice.com?url=http:/cp.com
/@https:/www.shouldmatchonce.com?url=https://cp.com
/@keyword
/directory
/
`
var substitution = "$1://"
fmt.Println(re.ReplaceAllString(str, substitution))
}