const regex = /(http[s]?):(\/+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http[s]?):(\\\/+)', 'gm')
const str = `/@https:/www.shouldmatch.com
/@http:/www.shouldmatch.com
/@https://www.shouldnotmatch.com
/@https:/www.shouldmatchtwice.com?url=https:/cp.com
/@https:/www.shouldmatchtwice.com?url=http:/cp.com
/@https:/www.shouldmatchonce.com?url=https://cp.com
/@keyword
/directory
/
`;
const subst = `$1://`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);