import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http[s]?):(\\/+)";
final String string = "/@https:/www.shouldmatch.com\n"
+ "/@http:/www.shouldmatch.com\n"
+ "/@https://www.shouldnotmatch.com\n"
+ "/@https:/www.shouldmatchtwice.com?url=https:/cp.com\n"
+ "/@https:/www.shouldmatchtwice.com?url=http:/cp.com\n"
+ "/@https:/www.shouldmatchonce.com?url=https://cp.com\n"
+ "/@keyword\n"
+ "/directory\n"
+ "/\n";
final String subst = "$1://";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}