#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(http[s]?):(\/+)"
Local $sString = "/@https:/www.shouldmatch.com" & @CRLF & _
"/@http:/www.shouldmatch.com" & @CRLF & _
"/@https://www.shouldnotmatch.com" & @CRLF & _
"/@https:/www.shouldmatchtwice.com?url=https:/cp.com" & @CRLF & _
"/@https:/www.shouldmatchtwice.com?url=http:/cp.com" & @CRLF & _
"/@https:/www.shouldmatchonce.com?url=https://cp.com" & @CRLF & _
"/@keyword" & @CRLF & _
"/directory" & @CRLF & _
"/" & @CRLF & _
""
Local $sSubst = "$1://"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)