$re = '/(http[s]?):(\/+)/m';
$str = '/@https:/www.shouldmatch.com
/@http:/www.shouldmatch.com
/@https://www.shouldnotmatch.com
/@https:/www.shouldmatchtwice.com?url=https:/cp.com
/@https:/www.shouldmatchtwice.com?url=http:/cp.com
/@https:/www.shouldmatchonce.com?url=https://cp.com
/@keyword
/directory
/
';
$subst = "$1://";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;