use strict;
my $str = '/@https:/www.shouldmatch.com
/@http:/www.shouldmatch.com
/@https://www.shouldnotmatch.com
/@https:/www.shouldmatchtwice.com?url=https:/cp.com
/@https:/www.shouldmatchtwice.com?url=http:/cp.com
/@https:/www.shouldmatchonce.com?url=https://cp.com
/@keyword
/directory
/
';
my $regex = qr/(http[s]?):(\/+)/mp;
my $subst = '$1://';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";