# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(http[s]?):(\/+)"
test_str = ("/@https:/www.shouldmatch.com\n"
"/@http:/www.shouldmatch.com\n"
"/@https://www.shouldnotmatch.com\n"
"/@https:/www.shouldmatchtwice.com?url=https:/cp.com\n"
"/@https:/www.shouldmatchtwice.com?url=http:/cp.com\n"
"/@https:/www.shouldmatchonce.com?url=https://cp.com\n"
"/@keyword\n"
"/directory\n"
"/\n")
subst = "$1://"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.