# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<iframe\s+.*?\s+src=(".*?").*?<\\/iframe>/<a href=$1>Link to youtube<\/a>/;t' <<< "<p><iframe allowfullscreen=\"\" class=\"media-element file-default\" data-fid=\"2219\" data-media-element=\"1\" frameborder=\"0\" height=\"360\" src=\"https://www.youtube.com/embed/sNEJOm4hSaw?feature=oembed\" width=\"640\"></iframe></p>"