use strict;
my $str = '<p><iframe allowfullscreen="" class="media-element file-default" data-fid="2219" data-media-element="1" frameborder="0" height="360" src="https://www.youtube.com/embed/sNEJOm4hSaw?feature=oembed" width="640"></iframe></p>';
my $regex = qr/<iframe\s+.*?\s+src=(".*?").*?<\/iframe>/p;
my $subst = '<a href=$1>Link to youtube</a>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";