// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<iframe\s+.*?\s+src=(".*?").*?<\/iframe>"#).unwrap();
let string = "<p><iframe allowfullscreen=\"\" class=\"media-element file-default\" data-fid=\"2219\" data-media-element=\"1\" frameborder=\"0\" height=\"360\" src=\"https://www.youtube.com/embed/sNEJOm4hSaw?feature=oembed\" width=\"640\"></iframe></p>";
let substitution = "<a href=$1>Link to youtube</a>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}