const regex = /<iframe\s+.*?\s+src=(".*?").*?<\/iframe>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<iframe\\s+.*?\\s+src=(".*?").*?<\\\/iframe>', '')
const str = `<p><iframe allowfullscreen="" class="media-element file-default" data-fid="2219" data-media-element="1" frameborder="0" height="360" src="https://www.youtube.com/embed/sNEJOm4hSaw?feature=oembed" width="640"></iframe></p>`;
const subst = `<a href=$1>Link to youtube</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);