import re
regex = re.compile(r"<iframe\s+.*?\s+src=(\".*?\").*?<\/iframe>")
test_str = "<p><iframe allowfullscreen=\"\" class=\"media-element file-default\" data-fid=\"2219\" data-media-element=\"1\" frameborder=\"0\" height=\"360\" src=\"https://www.youtube.com/embed/sNEJOm4hSaw?feature=oembed\" width=\"640\"></iframe></p>"
subst = "<a href=$1>Link to youtube</a>"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)