using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<iframe\s+.*?\s+src=("".*?"").*?<\/iframe>";
string substitution = @"<a href=$1>Link to youtube</a>";
string input = @"<p><iframe allowfullscreen="" class=""media-element file-default"" data-fid=""2219"" data-media-element=""1"" frameborder=""0"" height=""360"" src=""https://www.youtube.com/embed/sNEJOm4hSaw?feature=oembed"" width=""640""></iframe></p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}