package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<iframe\s+.*?\s+src=(".*?").*?<\/iframe>`)
var str = []byte(`<p><iframe allowfullscreen="" class="media-element file-default" data-fid="2219" data-media-element="1" frameborder="0" height="360" src="https://www.youtube.com/embed/sNEJOm4hSaw?feature=oembed" width="640"></iframe></p>`)
var substitution = []byte("<a href=$1>Link to youtube</a>")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}