package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`02, 80, 10, 10, 00, 01, 03, 91`)
var str = []byte(`02, 80, 10, 10, 00, 01, 03, 91`)
var substitution = []byte("P11")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}