use strict;
my $str = '02, 80, 10, 10, 00, 01, 03, 91';
my $regex = qr/02, 80, 10, 10, 00, 01, 03, 91/p;
my $subst = 'P11';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";