import Foundation
let pattern = #"02, 80, 10, 10, 00, 01, 03, 91"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"02, 80, 10, 10, 00, 01, 03, 91"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"P11"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}