using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+(<.+>)\s+(@.+)\)\s+(@.+)\)\s+(@.+\))\s+(<.+>)";
string substitution = @"<div class=""form-group"">\n\t\2, new { @class = ""control-label"" })\n\t<div class=""input-group"">\n\t\t\3, new { @class = ""form-control"" })\n\t\t\4\n\t</div>\n</div>\n";
string input = @" <div class=""mr-data-inputfield"">
@Html.LabelFor(m => m.Device.ShortDescription)
@Html.TextBoxFor(m => m.Device.ShortDescription, new { style = ""width: 400px;"" })
@Html.ValidationMessageFor(m => m.Device.ShortDescription)
</div>
<div class=""mr-data-inputfield"">
@Html.LabelFor(m => m.Device.LongDescription)
@Html.TextAreaFor(m => m.Device.LongDescription)
@Html.ValidationMessageFor(m => m.Device.LongDescription)
</div>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}