// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\s+(<.+>)\s+(@.+)\)\s+(@.+)\)\s+(@.+\))\s+(<.+>)").unwrap();
let string = " <div class=\"mr-data-inputfield\">
@Html.LabelFor(m => m.Device.ShortDescription)
@Html.TextBoxFor(m => m.Device.ShortDescription, new { style = \"width: 400px;\" })
@Html.ValidationMessageFor(m => m.Device.ShortDescription)
</div>
<div class=\"mr-data-inputfield\">
@Html.LabelFor(m => m.Device.LongDescription)
@Html.TextAreaFor(m => m.Device.LongDescription)
@Html.ValidationMessageFor(m => m.Device.LongDescription)
</div>";
let substitution = "<div class=\"form-group\">\\n\\t\\2, new { @class = \"control-label\" })\\n\\t<div class=\"input-group\">\\n\\t\\t\\3, new { @class = \"form-control\" })\\n\\t\\t\\4\\n\\t</div>\\n</div>\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}