use strict;
my $str = ' <div class="mr-data-inputfield">
@Html.LabelFor(m => m.Device.ShortDescription)
@Html.TextBoxFor(m => m.Device.ShortDescription, new { style = "width: 400px;" })
@Html.ValidationMessageFor(m => m.Device.ShortDescription)
</div>
<div class="mr-data-inputfield">
@Html.LabelFor(m => m.Device.LongDescription)
@Html.TextAreaFor(m => m.Device.LongDescription)
@Html.ValidationMessageFor(m => m.Device.LongDescription)
</div>';
my $regex = qr/\s+(<.+>)\s+(@.+)\)\s+(@.+)\)\s+(@.+\))\s+(<.+>)/mip;
my $subst = '<div class="form-group">\\n\\t\\2, new { @class = "control-label" })\\n\\t<div class="input-group">\\n\\t\\t\\3, new { @class = "form-control" })\\n\\t\\t\\4\\n\\t</div>\\n</div>\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";