re = /\s+(<.+>)\s+(@.+)\)\s+(@.+)\)\s+(@.+\))\s+(<.+>)/mi
str = ' <div class="mr-data-inputfield">
@Html.LabelFor(m => m.Device.ShortDescription)
@Html.TextBoxFor(m => m.Device.ShortDescription, new { style = "width: 400px;" })
@Html.ValidationMessageFor(m => m.Device.ShortDescription)
</div>
<div class="mr-data-inputfield">
@Html.LabelFor(m => m.Device.LongDescription)
@Html.TextAreaFor(m => m.Device.LongDescription)
@Html.ValidationMessageFor(m => m.Device.LongDescription)
</div>'
subst = '<div class="form-group">\\n\\t\\2, new { @class = "control-label" })\\n\\t<div class="input-group">\\n\\t\\t\\3, new { @class = "form-control" })\\n\\t\\t\\4\\n\\t</div>\\n</div>\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result