import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+(<.+>)\\s+(@.+)\\)\\s+(@.+)\\)\\s+(@.+\\))\\s+(<.+>)";
final String string = " <div class=\"mr-data-inputfield\">\n"
+ " @Html.LabelFor(m => m.Device.ShortDescription)\n"
+ " @Html.TextBoxFor(m => m.Device.ShortDescription, new { style = \"width: 400px;\" })\n"
+ " @Html.ValidationMessageFor(m => m.Device.ShortDescription)\n"
+ " </div>\n"
+ " <div class=\"mr-data-inputfield\">\n"
+ " @Html.LabelFor(m => m.Device.LongDescription)\n"
+ " @Html.TextAreaFor(m => m.Device.LongDescription)\n"
+ " @Html.ValidationMessageFor(m => m.Device.LongDescription)\n"
+ " </div>";
final String subst = "<div class=\"form-group\">\\n\\t\\2, new { @class = \"control-label\" })\\n\\t<div class=\"input-group\">\\n\\t\\t\\3, new { @class = \"form-control\" })\\n\\t\\t\\4\\n\\t</div>\\n</div>\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}